summaryrefslogtreecommitdiffstats
path: root/kicker/applets/launcher/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kicker/applets/launcher/Makefile.am')
-rw-r--r--kicker/applets/launcher/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/kicker/applets/launcher/Makefile.am b/kicker/applets/launcher/Makefile.am
new file mode 100644
index 000000000..a101c6ccf
--- /dev/null
+++ b/kicker/applets/launcher/Makefile.am
@@ -0,0 +1,27 @@
+
+INCLUDES = -I$(top_srcdir)/kicker/libkicker -I$(top_srcdir)/kicker/kicker/ui $(all_includes)
+
+kde_module_LTLIBRARIES = launcher_panelapplet.la
+
+launcher_panelapplet_la_SOURCES = quicklauncher.skel quicklauncher.cpp quickbutton.cpp quickaddappsmenu.cpp flowgridmanager.cpp popularity.cpp configdlgbase.ui prefs.kcfgc configdlg.cpp
+
+METASOURCES = AUTO
+noinst_HEADERS = quicklauncher.h quickbutton.h quickaddappsmenu.h easyvector.h quickbuttongroup.h flowgridmanager.h popularity.h configdlg.h
+
+lnkdir = $(kde_datadir)/kicker/applets
+lnk_DATA = quicklauncher.desktop
+
+EXTRA_DIST = $(lnk_DATA)
+
+launcher_panelapplet_la_LDFLAGS = -module $(KDE_RPATH) $(all_libraries) -avoid-version -no-undefined
+launcher_panelapplet_la_LIBADD = ../../kicker/core/libkicker_core.la ../../kicker/buttons/libkicker_buttons.la \
+ ../../kicker/ui/libkicker_ui.la ../../libkicker/libkickermain.la $(LIB_KIO) \
+ $(LIB_KSYCOCA) $(LIB_KDEUI) $(LIB_KUTILS)
+
+kde_kcfg_DATA = launcherapplet.kcfg
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/quicklauncher.pot
+
+srcdoc:
+ kdoc -a -p -H -d $$HOME/web/src/quicklauncher quicklauncher *.h -lqt -lkdecore -lkdeui