summaryrefslogtreecommitdiffstats
path: root/kicker/applets/naughty/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kicker/applets/naughty/CMakeLists.txt')
-rw-r--r--kicker/applets/naughty/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/kicker/applets/naughty/CMakeLists.txt b/kicker/applets/naughty/CMakeLists.txt
index 6f6b9d47a..b4fdcc9b0 100644
--- a/kicker/applets/naughty/CMakeLists.txt
+++ b/kicker/applets/naughty/CMakeLists.txt
@@ -11,6 +11,12 @@
# FIXME seems that on freebsd is needed smth named LIB_KVM
+if ( ${CMAKE_SYSTEM_NAME} MATCHES "NetBSD" )
+ set( LIB_KVM "-lkvm")
+else()
+ set( LIB_KVM "")
+endif()
+
include_directories(
${CMAKE_CURRENT_BINARY_DIR}
${CMAKE_SOURCE_DIR}/kicker/libkicker
@@ -35,6 +41,6 @@ tde_add_kpart( naughty_panelapplet AUTOMOC
SOURCES
NaughtyProcessMonitor.cpp NaughtyConfigDialog.cpp
NaughtyApplet.cpp
- LINK kickermain-shared
+ LINK kickermain-shared ${LIB_KVM}
DESTINATION ${PLUGIN_INSTALL_DIR}
)