summaryrefslogtreecommitdiffstats
path: root/kioslave/home/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kioslave/home/Makefile.am')
-rw-r--r--kioslave/home/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/kioslave/home/Makefile.am b/kioslave/home/Makefile.am
new file mode 100644
index 000000000..be10e5bcc
--- /dev/null
+++ b/kioslave/home/Makefile.am
@@ -0,0 +1,32 @@
+SUBDIRS= . kdedmodule
+# wizard
+
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = kio_home.la
+
+kio_home_la_SOURCES = dummy.cpp
+kio_home_la_LIBADD = libkiohome.la $(LIB_KIO)
+kio_home_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) -no-undefined
+
+dummy.cpp:
+ echo > dummy.cpp
+
+kde_services_DATA = home.protocol
+
+noinst_LTLIBRARIES = libkiohome.la
+libkiohome_la_SOURCES = kio_home.cpp homeimpl.cpp
+
+check_PROGRAMS = testhome
+testhome_SOURCES = testhome.cpp
+testhome_LDADD = libkiohome.la $(LIB_KIO)
+testhome_LDFLAGS = $(all_libraries)
+
+## TODO in unsermake: TESTS = testhome
+check: testhome
+ ./testhome
+
+messages:
+ $(XGETTEXT) `find . -name "*.cc" -o -name "*.cpp" -o -name "*.h"` -o $(podir)/kio_home.pot
+