summaryrefslogtreecommitdiffstats
path: root/kioslave/nntp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kioslave/nntp/Makefile.am')
-rw-r--r--kioslave/nntp/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/kioslave/nntp/Makefile.am b/kioslave/nntp/Makefile.am
new file mode 100644
index 000000000..b06d31600
--- /dev/null
+++ b/kioslave/nntp/Makefile.am
@@ -0,0 +1,19 @@
+INCLUDES= -I$(srcdir)/../.. -I$(srcdir)/.. $(all_includes)
+
+####### Files
+
+kde_module_LTLIBRARIES = kio_nntp.la
+
+kio_nntp_la_SOURCES = nntp.cpp
+kio_nntp_la_LIBADD = $(LIB_KIO)
+kio_nntp_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+METASOURCES = AUTO
+
+noinst_HEADERS = nntp.h
+
+kdelnk_DATA = nntp.protocol nntps.protocol
+kdelnkdir = $(kde_servicesdir)
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kio_nntp.pot