summaryrefslogtreecommitdiffstats
path: root/konqueror/about/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'konqueror/about/CMakeLists.txt')
-rw-r--r--konqueror/about/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/konqueror/about/CMakeLists.txt b/konqueror/about/CMakeLists.txt
new file mode 100644
index 000000000..55e8f4462
--- /dev/null
+++ b/konqueror/about/CMakeLists.txt
@@ -0,0 +1,44 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TDE_LIBRARY_DIRS}
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES konq_aboutpage.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES konqaboutpage.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+
+install( FILES
+ box-centre-konqueror.png top-right-konqueror.png
+ lightning.png launch.html intro.html specs.html
+ tips.html plugins.html plugins_rtl.html konq.css
+ DESTINATION ${DATA_INSTALL_DIR}/konqueror/about )
+
+
+##### konq_aboutpage (module) ###################
+
+set( target konq_aboutpage )
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES konq_aboutpage.cc
+ LINK khtml-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)