summaryrefslogtreecommitdiffstats
path: root/konqueror/remoteencodingplugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'konqueror/remoteencodingplugin/CMakeLists.txt')
-rw-r--r--konqueror/remoteencodingplugin/CMakeLists.txt48
1 files changed, 48 insertions, 0 deletions
diff --git a/konqueror/remoteencodingplugin/CMakeLists.txt b/konqueror/remoteencodingplugin/CMakeLists.txt
new file mode 100644
index 000000000..35c947858
--- /dev/null
+++ b/konqueror/remoteencodingplugin/CMakeLists.txt
@@ -0,0 +1,48 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/libkonq
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TDE_LIBRARY_DIRS}
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES
+ kremoteencodingplugin.rc kremoteencodingplugin.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/konqiconview/kpartplugins )
+
+install( FILES
+ kremoteencodingplugin.rc kremoteencodingplugin.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/konqlistview/kpartplugins )
+
+
+##### konq_remoteencoding (module) ##############
+
+set( target konq_remoteencoding )
+
+set( ${target}_SRCS
+ kremoteencodingplugin.cpp
+)
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES ${${target}_SRCS}
+ LINK konq-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)