summaryrefslogtreecommitdiffstats
path: root/konqueror/sidebar/trees/init/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'konqueror/sidebar/trees/init/CMakeLists.txt')
-rw-r--r--konqueror/sidebar/trees/init/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/konqueror/sidebar/trees/init/CMakeLists.txt b/konqueror/sidebar/trees/init/CMakeLists.txt
new file mode 100644
index 000000000..02df2aba3
--- /dev/null
+++ b/konqueror/sidebar/trees/init/CMakeLists.txt
@@ -0,0 +1,34 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( remote )
+add_subdirectory( services )
+
+
+##### other data ################################
+
+install( FILES
+ home.desktop root.desktop history.desktop bookmarks.desktop
+ services.desktop remote.desktop system.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/konqsidebartng/entries )
+
+install( FILES
+ home.desktop root.desktop history.desktop bookmarks.desktop
+ services.desktop remote.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/konqsidebartng/kicker_entries )
+
+install( FILES
+ virtualfolderadd.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/konqsidebartng/add )
+
+install( FILES
+ history_module.desktop dirtree_module.desktop bookmarks_module.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/konqsidebartng/dirtree )