summaryrefslogtreecommitdiffstats
path: root/kpager/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kpager/Makefile.am')
-rw-r--r--kpager/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/kpager/Makefile.am b/kpager/Makefile.am
new file mode 100644
index 000000000..d33d8852e
--- /dev/null
+++ b/kpager/Makefile.am
@@ -0,0 +1,22 @@
+INCLUDES= $(all_includes)
+
+bin_PROGRAMS = kpager
+
+kpager_SOURCES = desktop.cpp kpager.cpp config.cpp windowdrag.cpp \
+ kpagerIface.skel main.cpp
+
+kpager_METASOURCES = AUTO
+kpager_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+
+kpager_LDADD = $(LIB_KDEUI)
+
+KDE_ICON = kpager
+
+xdg_apps_DATA = kpager.desktop
+
+install-data-local: uninstall.desktop
+ $(mkinstalldirs) $(DESTDIR)$(kde_appsdir)/Utilities
+ $(INSTALL_DATA) $(srcdir)/uninstall.desktop $(DESTDIR)$(kde_appsdir)/Utilities/kpager.desktop
+
+messages:
+ $(XGETTEXT) *.cpp *.h -o $(podir)/kpager.pot