summaryrefslogtreecommitdiffstats
path: root/ksplashml/themeengine/default/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ksplashml/themeengine/default/Makefile.am')
-rw-r--r--ksplashml/themeengine/default/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/ksplashml/themeengine/default/Makefile.am b/ksplashml/themeengine/default/Makefile.am
new file mode 100644
index 000000000..e3f522751
--- /dev/null
+++ b/ksplashml/themeengine/default/Makefile.am
@@ -0,0 +1,17 @@
+
+INCLUDES = -I$(srcdir)/.. -I$(srcdir)/../.. $(all_includes)
+
+noinst_LTLIBRARIES = libthemedefault.la
+libthemedefault_la_SOURCES = themelegacy.cpp
+libthemedefault_la_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+libthemedefault_la_LIBADD = $(LIB_KDEUI) ../libksplashthemes.la
+
+kde_module_LTLIBRARIES = ksplashdefault.la
+
+ksplashdefault_la_SOURCES = main.cpp
+ksplashdefault_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(KDE_PLUGIN) -module
+ksplashdefault_la_LIBADD = $(LIB_KDEUI) ../libksplashthemes.la libthemedefault.la
+METASOURCES = AUTO
+
+servicesdir = $(kde_servicesdir)
+services_DATA = ksplashdefault.desktop