summaryrefslogtreecommitdiffstats
path: root/ksysguard/gui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ksysguard/gui/CMakeLists.txt')
-rw-r--r--ksysguard/gui/CMakeLists.txt18
1 files changed, 15 insertions, 3 deletions
diff --git a/ksysguard/gui/CMakeLists.txt b/ksysguard/gui/CMakeLists.txt
index 7313b6b5d..504fbeb5b 100644
--- a/ksysguard/gui/CMakeLists.txt
+++ b/ksysguard/gui/CMakeLists.txt
@@ -30,10 +30,22 @@ link_directories(
##### other data ################################
-install( FILES ksysguard.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
-install( FILES x-ksysguard.desktop DESTINATION ${MIME_INSTALL_DIR}/application )
+tde_create_translated_desktop(
+ SOURCE ksysguard.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+ PO_DIR ksysguard-desktops
+)
+tde_create_translated_desktop(
+ SOURCE x-ksysguard.desktop
+ DESTINATION ${MIME_INSTALL_DIR}/application
+ PO_DIR ksysguard-desktops
+)
install( FILES ProcessTable.sgrd SystemLoad.sgrd KSysGuardApplet.xml ksysguardui.rc DESTINATION ${DATA_INSTALL_DIR}/ksysguard )
-install( FILES ksysguardapplet.desktop DESTINATION ${DATA_INSTALL_DIR}/kicker/applets )
+tde_create_translated_desktop(
+ SOURCE ksysguardapplet.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kicker/applets
+ PO_DIR ksysguard-desktops
+)
##### sysguard_panelapplet (module) #############