summaryrefslogtreecommitdiffstats
path: root/ksysguard/ksysguardd/Linux/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ksysguard/ksysguardd/Linux/CMakeLists.txt')
-rw-r--r--ksysguard/ksysguardd/Linux/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/ksysguard/ksysguardd/Linux/CMakeLists.txt b/ksysguard/ksysguardd/Linux/CMakeLists.txt
new file mode 100644
index 000000000..b0cff4205
--- /dev/null
+++ b/ksysguard/ksysguardd/Linux/CMakeLists.txt
@@ -0,0 +1,32 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_definitions( -D_GNU_SOURCE )
+
+if( WITH_I8K )
+ add_definitions( -DHAVE_I8K_SUPPORT )
+endif()
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/ksysguard/CContLib
+ ${CMAKE_SOURCE_DIR}/ksysguard/ksysguardd
+)
+
+
+##### ksysguardd (static) #######################
+
+tde_add_library( ksysguardd STATIC
+ SOURCES
+ ProcessList.c Memory.c stat.c netdev.c apm.c acpi.c
+ loadavg.c cpuinfo.c lmsensors.c netstat.c diskstat.c
+ logfile.c i8k.c
+)