summaryrefslogtreecommitdiffstats
path: root/kwin/kcmkwin/kwindecoration/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kwin/kcmkwin/kwindecoration/Makefile.am')
-rw-r--r--kwin/kcmkwin/kwindecoration/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/kwin/kcmkwin/kwindecoration/Makefile.am b/kwin/kcmkwin/kwindecoration/Makefile.am
new file mode 100644
index 000000000..4d908001f
--- /dev/null
+++ b/kwin/kcmkwin/kwindecoration/Makefile.am
@@ -0,0 +1,18 @@
+INCLUDES = -I$(srcdir)/../../lib $(all_includes)
+
+kde_module_LTLIBRARIES = kcm_kwindecoration.la
+
+kcm_kwindecoration_la_SOURCES = kwindecoration.cpp buttons.cpp kwindecorationIface.skel preview.cpp
+noinst_HEADERS = kwindecoration.h kwindecorationIface.h buttons.h preview.h
+
+kcm_kwindecoration_la_LDFLAGS = \
+ -module -avoid-version $(all_libraries) -no-undefined
+
+kcm_kwindecoration_la_LIBADD = $(LIB_KDEUI) ../../lib/libkdecorations.la
+
+METASOURCES = AUTO
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kcmkwindecoration.pot
+
+xdg_apps_DATA = kwindecoration.desktop