summaryrefslogtreecommitdiffstats
path: root/tdepasswd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdepasswd/Makefile.am')
-rw-r--r--tdepasswd/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/tdepasswd/Makefile.am b/tdepasswd/Makefile.am
new file mode 100644
index 000000000..65261086d
--- /dev/null
+++ b/tdepasswd/Makefile.am
@@ -0,0 +1,17 @@
+
+SUBDIRS = kcm
+
+bin_PROGRAMS = tdepasswd
+tdepasswd_SOURCES = tdepasswd.cpp passwd.cpp passwddlg.cpp
+tdepasswd_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -ltdetexteditor
+tdepasswd_LDADD = $(LIB_KIO)
+
+METASOURCES = AUTO
+AM_CPPFLAGS= -I$(top_srcdir)/libkonq $(all_includes)
+noinst_HEADERS = passwd.h passwddlg.h
+
+xdg_apps_DATA = tdepasswd.desktop
+
+messages:
+ $(XGETTEXT) $(tdepasswd_SOURCES) -o $(podir)/tdepasswd.pot
+