summaryrefslogtreecommitdiffstats
path: root/tdeprint/printmgr/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdeprint/printmgr/Makefile.am')
-rw-r--r--tdeprint/printmgr/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/tdeprint/printmgr/Makefile.am b/tdeprint/printmgr/Makefile.am
new file mode 100644
index 000000000..d0932829a
--- /dev/null
+++ b/tdeprint/printmgr/Makefile.am
@@ -0,0 +1,18 @@
+AM_CPPFLAGS = -D_KDEPRINT_COMPILE
+
+INCLUDES = $(all_includes)
+
+kde_module_LTLIBRARIES = kcm_printmgr.la
+
+kcm_printmgr_la_SOURCES = kcmprintmgr.cpp
+kcm_printmgr_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+kcm_printmgr_la_LIBADD = -ltdeprint_management
+
+noinst_HEADERS = kcmprintmgr.h
+
+KDE_ICON = printmgr
+
+xdg_apps_DATA = printers.desktop
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmprintmgr.pot