summaryrefslogtreecommitdiffstats
path: root/tdeprint/tdeprint_part/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdeprint/tdeprint_part/Makefile.am')
-rw-r--r--tdeprint/tdeprint_part/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/tdeprint/tdeprint_part/Makefile.am b/tdeprint/tdeprint_part/Makefile.am
new file mode 100644
index 000000000..e27404a0f
--- /dev/null
+++ b/tdeprint/tdeprint_part/Makefile.am
@@ -0,0 +1,24 @@
+AM_CPPFLAGS = -D_KDEPRINT_COMPILE
+
+kde_module_LTLIBRARIES = libtdeprint_part.la
+
+libtdeprint_part_la_SOURCES = printpart.cpp
+libtdeprint_part_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+libtdeprint_part_la_LIBADD = -ltdeprint_management $(LIB_KPARTS)
+
+noinst_HEADERS = printpart.h
+
+METASOURCES = AUTO
+INCLUDES = $(all_includes)
+
+# service
+myservice_DATA = tdeprint_part.desktop
+myservicedir = $(kde_servicesdir)
+
+# UI file
+myrcfile_DATA = tdeprint_part.rc
+myrcfiledir = $(kde_datadir)/tdeprint_part
+
+messages: rc.cpp
+ $(EXTRACTRC) tdeprint_part.rc >> rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/tdeprint_part.pot