summaryrefslogtreecommitdiffstats
path: root/twin/clients/plastik/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'twin/clients/plastik/Makefile.am')
-rw-r--r--twin/clients/plastik/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/twin/clients/plastik/Makefile.am b/twin/clients/plastik/Makefile.am
new file mode 100644
index 000000000..c1757891d
--- /dev/null
+++ b/twin/clients/plastik/Makefile.am
@@ -0,0 +1,19 @@
+AUTOMAKE_OPTIONS = foreign
+
+SUBDIRS = config
+
+KDE_CXXFLAGS = -DQT_PLUGIN
+
+INCLUDES = -I$(srcdir)/../../lib $(all_includes)
+
+twindir = $(kde_datadir)/twin/
+twin_DATA = plastik.desktop
+
+kde_module_LTLIBRARIES = twin3_plastik.la
+twin3_plastik_la_SOURCES = plastik.cpp plastikclient.cpp plastikbutton.cpp misc.cpp
+twin3_plastik_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module
+twin3_plastik_la_LIBADD = $(LIB_TDEUI) ../../lib/libtdecorations.la
+twin3_plastik_la_METASOURCES = AUTO
+
+DISTCLEANFILES = $(twin3_plastik_la_METASOURCES)
+