summaryrefslogtreecommitdiffstats
path: root/twin/compton-tde/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'twin/compton-tde/CMakeLists.txt')
-rw-r--r--twin/compton-tde/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/twin/compton-tde/CMakeLists.txt b/twin/compton-tde/CMakeLists.txt
index f73f09ee5..6a2d71339 100644
--- a/twin/compton-tde/CMakeLists.txt
+++ b/twin/compton-tde/CMakeLists.txt
@@ -31,6 +31,8 @@ include_directories(
# WITH_XINNERAMA -> CONFIG_XINERAMA
# WITH_OPENGL -> CONFIG_VSYNC_OPENGL
# WITH_OPENGL -> CONFIG_VSYNC_OPENGL_GLSL
+# WITH_OPENGL -> CONFIG_VSYNC_OPENGL_FBO
+# WITH_OPENGL -> CONFIG_GLX_XSYNC
# WITH_PCRE -> CONFIG_REGEX_PCRE
# WITH_PCRE -> CONFIG_REGEX_PCRE_JIT
# WITH_LIBCONFIG -> CONFIG_LIBCONFIG
@@ -50,6 +52,8 @@ set( compton_SRCS compton.c )
if( WITH_OPENGL )
set( CONFIG_VSYNC_OPENGL ${WITH_OPENGL} )
set( CONFIG_VSYNC_OPENGL_GLSL ${WITH_OPENGL} )
+ set( CONFIG_VSYNC_OPENGL_FBO ${WITH_OPENGL} )
+ set( CONFIG_GLX_XSYNC ${WITH_OPENGL} )
list( APPEND compton_LIBRARIES ${GL_LIBRARIES})
list( APPEND compton_SRCS opengl.c )
endif( )