summaryrefslogtreecommitdiffstats
path: root/kjsembed/plugins/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit90825e2392b2d70e43c7a25b8a3752299a933894 (patch)
treee33aa27f02b74604afbfd0ea4f1cfca8833d882a /kjsembed/plugins/Makefile.am
downloadtdebindings-90825e2392b2d70e43c7a25b8a3752299a933894.tar.gz
tdebindings-90825e2392b2d70e43c7a25b8a3752299a933894.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebindings@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kjsembed/plugins/Makefile.am')
-rw-r--r--kjsembed/plugins/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/kjsembed/plugins/Makefile.am b/kjsembed/plugins/Makefile.am
new file mode 100644
index 00000000..f3071bb2
--- /dev/null
+++ b/kjsembed/plugins/Makefile.am
@@ -0,0 +1,38 @@
+INCLUDES= -I$(srcdir)/.. -I$(srcdir)/../.. $(all_includes)
+KDE_CXXFLAGS = -DQT_NO_ASCII_CAST -DQT_CLEAN_NAMESPACE
+
+kde_module_LTLIBRARIES = libcustomobjectplugin.la libcustomqobjectplugin.la \
+ libimagefxplugin.la libqprocessplugin.la libfileitemplugin.la
+METASOURCES = AUTO
+
+# the Plugin's source, library search path, and link libraries
+libcustomobjectplugin_la_SOURCES = customobject_plugin.cpp
+libcustomobjectplugin_la_LDFLAGS = -module $(KDE_PLUGIN) $(KDE_RPATH) $(all_libraries)
+libcustomobjectplugin_la_LIBADD = $(LIB_QT) $(LIB_KPARTS) $(LIB_KDECORE) $(LIB_KFILE) ../libkjsembed.la
+
+# the Plugin's source, library search path, and link libraries
+libcustomqobjectplugin_la_SOURCES = customqobject_plugin.cpp
+libcustomqobjectplugin_la_LDFLAGS = -module $(KDE_PLUGIN) $(KDE_RPATH) $(all_libraries)
+libcustomqobjectplugin_la_LIBADD = $(LIB_QT) $(LIB_KPARTS) $(LIB_KDECORE) $(LIB_KFILE) ../libkjsembed.la
+
+# the Plugin's source, library search path, and link libraries
+libimagefxplugin_la_SOURCES = imagefx_plugin.cpp
+libimagefxplugin_la_LDFLAGS = -module $(KDE_PLUGIN) $(KDE_RPATH) $(all_libraries)
+libimagefxplugin_la_LIBADD = $(LIB_QT) $(LIB_KPARTS) $(LIB_KDECORE) $(LIB_KFILE) ../libkjsembed.la
+
+# the Plugin's source, library search path, and link libraries
+libqprocessplugin_la_SOURCES = qprocess_plugin.cpp
+libqprocessplugin_la_LDFLAGS = -module $(KDE_PLUGIN) $(KDE_RPATH) $(all_libraries)
+libqprocessplugin_la_LIBADD = $(LIB_QT) $(LIB_KPARTS) $(LIB_KDECORE) $(LIB_KFILE) ../libkjsembed.la
+
+# the Plugin's source, library search path, and link libraries
+libfileitemplugin_la_SOURCES = kfileitemloader.cpp
+libfileitemplugin_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+libfileitemplugin_la_LIBADD = $(LIB_KPARTS) $(LIB_KFILE) ../libkjsembed.la
+
+
+# this is where the desktop file will go
+plugindesktopdir = $(kde_servicesdir)
+plugindesktop_DATA = customobject_plugin.desktop customqobject_plugin.desktop imagefx_plugin.desktop\
+ qprocess_plugin.desktop kfileitem_plugin.desktop
+