summaryrefslogtreecommitdiffstats
path: root/kjsembed/docs/embedding/simple-embed/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kjsembed/docs/embedding/simple-embed/Makefile.am')
-rw-r--r--kjsembed/docs/embedding/simple-embed/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/kjsembed/docs/embedding/simple-embed/Makefile.am b/kjsembed/docs/embedding/simple-embed/Makefile.am
new file mode 100644
index 00000000..44607f91
--- /dev/null
+++ b/kjsembed/docs/embedding/simple-embed/Makefile.am
@@ -0,0 +1,40 @@
+## Makefile.am for embedjs
+
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+bin_PROGRAMS = embedjs
+
+# set the include path for X, qt and KDE
+INCLUDES = -I$(top_srcdir) $(all_includes)
+
+# the library search path.
+embedjs_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+
+# the libraries to link against.
+embedjs_LDADD = $(LIB_KFILE) $(LIB_KDEPRINT) -lkjs $(top_builddir)/kjsembed/libkjsembed.la
+
+# which sources should be compiled for embedjs
+embedjs_SOURCES = main.cpp embedview.ui embedviewimp.cpp
+
+# these are the headers for your project
+
+
+# client stuff
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/embedjs.pot
+
+KDE_ICON = embedjs
+
+# this is where the kdelnk file will go
+kdelnkdir = $(kde_appsdir)/Utilities
+kdelnk_DATA = embedjs.desktop
+
+# this is where the XML-GUI resource file goes
+rcdir = $(kde_datadir)/embedjs
+rc_DATA = embedjsui.rc
+noinst_HEADERS = embedviewimp.h
+noinst_DATA = test.js