summaryrefslogtreecommitdiffstats
path: root/klatin/klatin/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce599e4f9f94b4eb00c1b5edb85bce5431ab3df2 (patch)
treed3bb9f5d25a2dc09ca81adecf39621d871534297 /klatin/klatin/Makefile.am
downloadtdeedu-ce599e4f9f94b4eb00c1b5edb85bce5431ab3df2.tar.gz
tdeedu-ce599e4f9f94b4eb00c1b5edb85bce5431ab3df2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeedu@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'klatin/klatin/Makefile.am')
-rw-r--r--klatin/klatin/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/klatin/klatin/Makefile.am b/klatin/klatin/Makefile.am
new file mode 100644
index 00000000..048d3c7f
--- /dev/null
+++ b/klatin/klatin/Makefile.am
@@ -0,0 +1,40 @@
+## Makefile.am for klatin
+
+# this has all of the subdirectories that make will recurse into. if
+# there are none, comment this out
+SUBDIRS = . data icons
+
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+bin_PROGRAMS = klatin
+
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# the library search path.
+klatin_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+
+# the libraries to link against.
+klatin_LDADD = $(LIB_KFILE) $(top_builddir)/libkdeedu/kdeeducore/libkdeeducore.la
+
+# which sources should be compiled for klatin
+klatin_SOURCES = main.cpp klatin.cpp klatingrammar.cpp klatinverbs.cpp klatinvocab.cpp \
+ klatinchoose.ui settings.kcfgc klatingrammarwidget.ui klatinvocabwidget.ui klatinverbswidget.ui \
+ klatinresultsdialog.ui klatinsettings_vocabpage.ui
+
+# these are the headers for your project
+noinst_HEADERS = klatin.h klatinverbs.h klatinvocab.h klatingrammar.h
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/klatin.pot
+
+xdg_apps_DATA = klatin.desktop
+kde_kcfg_DATA = klatin.kcfg
+
+# this is where the XML-GUI resource file goes
+rcdir = $(kde_datadir)/klatin
+rc_DATA = klatinui.rc
+