summaryrefslogtreecommitdiffstats
path: root/libtdeedu/tdeeduui/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <g-gregory@gmx.fr>2019-06-27 16:35:25 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-06-27 16:35:25 +0200
commitd4a1613e9f119ae68c695ab60f8d9856d1a54a52 (patch)
tree6de888ef76667e28c81832dc104c19b158859b9b /libtdeedu/tdeeduui/tests/CMakeLists.txt
parent9fb4e1ccde0b89b413bfdc8ae62f8178ecad5483 (diff)
downloadtdeedu-d4a1613e9f119ae68c695ab60f8d9856d1a54a52.tar.gz
tdeedu-d4a1613e9f119ae68c695ab60f8d9856d1a54a52.zip
Conversion to the cmake building system.
Add includes to UI files to resolve FTBFS. Signed-off-by: gregory guy <g-gregory@gmx.fr> Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'libtdeedu/tdeeduui/tests/CMakeLists.txt')
-rw-r--r--libtdeedu/tdeeduui/tests/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/libtdeedu/tdeeduui/tests/CMakeLists.txt b/libtdeedu/tdeeduui/tests/CMakeLists.txt
new file mode 100644
index 00000000..eeb72a24
--- /dev/null
+++ b/libtdeedu/tdeeduui/tests/CMakeLists.txt
@@ -0,0 +1,26 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_SOURCE_DIR}/tdeeduui
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### entrydialogs (test)
+
+tde_add_check_executable( entrydialogs AUTOMOC
+
+ SOURCES
+ entrydialogs.cpp
+ LINK
+ tdeeduui-shared
+
+ TEST
+)