summaryrefslogtreecommitdiffstats
path: root/kig/modes/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kig/modes/Makefile.am')
-rw-r--r--kig/modes/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/kig/modes/Makefile.am b/kig/modes/Makefile.am
new file mode 100644
index 00000000..5f7518e5
--- /dev/null
+++ b/kig/modes/Makefile.am
@@ -0,0 +1,39 @@
+INCLUDES=$(all_includes)
+
+noinst_LTLIBRARIES=libmodes.la
+libmodes_la_SOURCES= \
+ base_mode.cc \
+ construct_mode.cc \
+ dragrectmode.cc \
+ edittype.cc \
+ edittypebase.ui \
+ label.cc \
+ linkslabel.cpp \
+ macro.cc \
+ macrowizard.cc \
+ macrowizardbase.ui \
+ mode.cc \
+ moving.cc \
+ normal.cc \
+ popup.cc \
+ textlabelwizard.cc \
+ textlabelwizardbase.ui \
+ typesdialog.cpp \
+ typesdialogbase.ui
+noinst_HEADERS=\
+ base_mode.h \
+ construct_mode.h \
+ dragrectmode.h \
+ edittype.h \
+ label.h \
+ linkslabel.h \
+ macro.h \
+ macrowizard.h \
+ mode.h \
+ moving.h \
+ normal.h \
+ popup.h \
+ textlabelwizard.h \
+ typesdialog.h
+
+METASOURCES=AUTO