summaryrefslogtreecommitdiffstats
path: root/kblackbox/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitc90c389a8a8d9d8661e9772ec4144c5cf2039f23 (patch)
tree6d8391395bce9eaea4ad78958617edb20c6a7573 /kblackbox/Makefile.am
downloadtdegames-c90c389a8a8d9d8661e9772ec4144c5cf2039f23.tar.gz
tdegames-c90c389a8a8d9d8661e9772ec4144c5cf2039f23.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdegames@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kblackbox/Makefile.am')
-rw-r--r--kblackbox/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/kblackbox/Makefile.am b/kblackbox/Makefile.am
new file mode 100644
index 00000000..813aff83
--- /dev/null
+++ b/kblackbox/Makefile.am
@@ -0,0 +1,22 @@
+SUBDIRS = pics
+
+INCLUDES = -I$(top_srcdir)/libkdegames $(all_includes)
+
+bin_PROGRAMS = kblackbox
+kblackbox_SOURCES = kbbgfx.cpp kbbgame.cpp util.cpp main.cpp
+kblackbox_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+kblackbox_LDADD = $(LIB_KDEGAMES)
+kblackbox_DEPENDENCIES = $(LIB_KDEGAMES_DEP)
+
+METASOURCES = AUTO
+KDE_ICON = kblackbox
+
+xdg_apps_DATA = kblackbox.desktop
+
+EXTRA_DIST = VERSION CHANGES $(xdg_apps_DATA)
+
+rcdir = $(kde_datadir)/kblackbox
+rc_DATA = kblackboxui.rc
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kblackbox.pot