summaryrefslogtreecommitdiffstats
path: root/ksokoban/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitc90c389a8a8d9d8661e9772ec4144c5cf2039f23 (patch)
tree6d8391395bce9eaea4ad78958617edb20c6a7573 /ksokoban/Makefile.am
downloadtdegames-c90c389a8a8d9d8661e9772ec4144c5cf2039f23.tar.gz
tdegames-c90c389a8a8d9d8661e9772ec4144c5cf2039f23.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdegames@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'ksokoban/Makefile.am')
-rw-r--r--ksokoban/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/ksokoban/Makefile.am b/ksokoban/Makefile.am
new file mode 100644
index 00000000..300d997e
--- /dev/null
+++ b/ksokoban/Makefile.am
@@ -0,0 +1,23 @@
+APPSDIR = $(kde_appsdir)/Games/TacticStrategy
+
+SUBDIRS=levels data images
+
+bin_PROGRAMS = ksokoban
+ksokoban_SOURCES = Bookmark.cpp History.cpp HtmlPrinter.cpp ImageData.cpp InternalCollections.cpp LevelCollection.cpp LevelMap.cpp MainWindow.cpp Map.cpp MapDelta.cpp ModalLabel.cpp Move.cpp MoveSequence.cpp PathFinder.cpp PlayField.cpp StaticImage.cpp main.cpp
+ksokoban_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+ksokoban_LDADD = $(LIB_KIO)
+
+noinst_HEADERS = Bookmark.h History.h HtmlPrinter.h ImageData.h InternalCollections.h LevelCollection.h LevelMap.h MainWindow.h Map.h MapDelta.h ModalLabel.h Move.h MoveSequence.h PathFinder.h PlayField.h Queue.h StaticImage.h
+
+METASOURCES= MainWindow.moc ModalLabel.moc PlayField.moc
+
+INCLUDES = $(all_includes)
+
+EXTRA_DIST=AUTHORS NEWS README TODO
+
+# we need theese deps for the automatic generation of other deps
+StaticImage.o: images/data.c
+InternalCollections.o: levels/data.c
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/ksokoban.pot