summaryrefslogtreecommitdiffstats
path: root/ksame/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ksame/Makefile.am')
-rw-r--r--ksame/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/ksame/Makefile.am b/ksame/Makefile.am
new file mode 100644
index 00000000..593a88f4
--- /dev/null
+++ b/ksame/Makefile.am
@@ -0,0 +1,24 @@
+
+bin_PROGRAMS = ksame
+INCLUDES = -I$(top_srcdir)/libkdegames -I$(top_srcdir)/libkdegames/highscore $(all_includes)
+
+ksame_SOURCES= main.cpp StoneField.cpp StoneWidget.cpp KSameWidget.cpp
+ksame_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+ksame_LDADD = $(LIB_KDEGAMES) $(LIB_KIO)
+ksame_DEPENDENCIES = $(LIB_KDEGAMES_DEP)
+
+METASOURCES = AUTO
+
+noinst_HEADERS = StoneField.h StoneWidget.h KSameWidget.h version.h
+
+xdg_apps_DATA = ksame.desktop
+
+appdir = $(kde_datadir)/ksame
+app_DATA = stones.png ksameui.rc eventsrc
+
+KDE_ICON = ksame
+
+EXTRA_DIST = $(app_DATA)
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/ksame.pot