summaryrefslogtreecommitdiffstats
path: root/ksvg/core/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-09 17:49:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-09 17:49:10 +0200
commit837dbafbea0c7f7bc73d27fda684ea2dededd547 (patch)
tree66811931fed182f8fa6f59547c6511a897adb734 /ksvg/core/CMakeLists.txt
parent00b9084c635fe29e7c5942ff508be2ca65893659 (diff)
downloadtdegraphics-837dbafbea0c7f7bc73d27fda684ea2dededd547.tar.gz
tdegraphics-837dbafbea0c7f7bc73d27fda684ea2dededd547.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ksvg/core/CMakeLists.txt')
-rw-r--r--ksvg/core/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/ksvg/core/CMakeLists.txt b/ksvg/core/CMakeLists.txt
index 4f3136d2..98f401db 100644
--- a/ksvg/core/CMakeLists.txt
+++ b/ksvg/core/CMakeLists.txt
@@ -35,9 +35,11 @@ install( FILES
##### other data ################################
-install( FILES
- ksvgrenderer.desktop
- DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE ksvgrenderer.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/ksvg-desktops
+)
##### ksvgcore (static) #########################