summaryrefslogtreecommitdiffstats
path: root/kview/kimageviewer/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-08 01:20:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-08 01:20:52 +0200
commit2a2437b3022a990bc9cded4d07c56a0d093b2a0c (patch)
treed00dc0c66bbaf157634036e8827011d2eb8ffd4b /kview/kimageviewer/CMakeLists.txt
parent4421872bb29f158a742d84d0c5b06106763427f1 (diff)
downloadtdegraphics-2a2437b3022a990bc9cded4d07c56a0d093b2a0c.tar.gz
tdegraphics-2a2437b3022a990bc9cded4d07c56a0d093b2a0c.zip
Simplify CMake rules for desktop file translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kview/kimageviewer/CMakeLists.txt')
-rw-r--r--kview/kimageviewer/CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/kview/kimageviewer/CMakeLists.txt b/kview/kimageviewer/CMakeLists.txt
index c3f25961..094da7c8 100644
--- a/kview/kimageviewer/CMakeLists.txt
+++ b/kview/kimageviewer/CMakeLists.txt
@@ -22,13 +22,11 @@ link_directories(
##### other data ################################
-foreach( _service kimageviewercanvas.desktop kimageviewer.desktop )
- tde_create_translated_desktop(
- SOURCE ${_service}
- DESTINATION ${SERVICETYPES_INSTALL_DIR}
- PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kview-desktops
- )
-endforeach()
+tde_create_translated_desktop(
+ SOURCE kimageviewercanvas.desktop kimageviewer.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR kview-desktops
+)
##### kimageviewer (shared) #####################