summaryrefslogtreecommitdiffstats
path: root/tdefile-plugins/raw/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:03:37 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:03:37 -0600
commit2e25fa39cd67cca2472d3eabdb478feb517d72a5 (patch)
tree63725962f632d152cbf20709191d39f6fc865966 /tdefile-plugins/raw/Makefile.am
parent190d88dfc662f3fc466c9d1f53acbbea65f33c49 (diff)
downloadtdegraphics-2e25fa39cd67cca2472d3eabdb478feb517d72a5.tar.gz
tdegraphics-2e25fa39cd67cca2472d3eabdb478feb517d72a5.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdefile-plugins/raw/Makefile.am')
-rw-r--r--tdefile-plugins/raw/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/tdefile-plugins/raw/Makefile.am b/tdefile-plugins/raw/Makefile.am
new file mode 100644
index 00000000..196aa4bd
--- /dev/null
+++ b/tdefile-plugins/raw/Makefile.am
@@ -0,0 +1,19 @@
+## Makefile.am for the raw thumbnail extration plugin
+
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = kcamerarawplugin.h
+
+kde_module_LTLIBRARIES = tdefile_raw.la
+
+tdefile_raw_la_SOURCES = kcamerarawplugin.cpp parse.c
+tdefile_raw_la_LIBADD = $(LIB_KIO)
+tdefile_raw_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+services_DATA = tdefile_raw.desktop
+servicesdir = $(kde_servicesdir)