summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-29 15:09:53 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-29 15:09:53 +0200
commitb21b72577a8b227d8980f9ed9611601861ef4bb3 (patch)
treeed5aca36ef06968819526a11aab4576db4216af1 /CMakeLists.txt
parentb9dd4dd6819f1fbfedf1b014a9f04d84d284986a (diff)
downloadtdeio-apt-b21b72577a8b227d8980f9ed9611601861ef4bb3.tar.gz
tdeio-apt-b21b72577a8b227d8980f9ed9611601861ef4bb3.zip
Use common rules for build and install translations.
Change documentation path to tdeioslave/apt. Change CMake project name to tdeio_apt. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cbb1886..513980d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,7 +12,7 @@ cmake_minimum_required( VERSION 2.8.12 )
#### general package setup
-project( tdeio-apt )
+project( tdeio_apt )
set( VERSION R14.1.0 )
@@ -68,9 +68,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+##### other data ################################
+
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
+
##### write configure files