summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-04-15 21:51:56 +0200
committergregory guy <gregory-tde@laposte.net>2020-04-15 21:51:56 +0200
commit634aaabc8f08f2f28442c00207bed03c186f8ea5 (patch)
treec8a79057d31b36f8fbfc96526f4a2800a7ea685d /CMakeLists.txt
parentf1f2e36798501c877816f15c602988204073b41d (diff)
downloadtdeio-ftps-634aaabc8f08f2f28442c00207bed03c186f8ea5.tar.gz
tdeio-ftps-634aaabc8f08f2f28442c00207bed03c186f8ea5.zip
Drop automake build support.
Add basic cmake build instructions. Rework of the README file. Add the MODULE directive to the build. Some cosmetics. Signed-off-by: gregory guy <gregory-tde@laposte.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1e10d5e..f78a59e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,13 +42,13 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
+option( BUILD_ALL "Build all" ON )
option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
@@ -68,7 +68,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
-tde_conditional_add_subdirectory( BUILD_ALL tdeio_ftps )
+tde_conditional_add_subdirectory( BUILD_ALL tdeio_ftps )
tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )