summaryrefslogtreecommitdiffstats
path: root/tdeio_ftps/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tdeio_ftps/CMakeLists.txt')
-rw-r--r--tdeio_ftps/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/tdeio_ftps/CMakeLists.txt b/tdeio_ftps/CMakeLists.txt
new file mode 100644
index 0000000..e61038b
--- /dev/null
+++ b/tdeio_ftps/CMakeLists.txt
@@ -0,0 +1,29 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### tdeio_ftps (kpart)
+
+tde_add_kpart( tdeio_ftps AUTOMOC
+ SOURCES ftp.cc
+ LINK tdecore-shared tdeio-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ FILES ftps.protocol
+ DESTINATION ${SERVICES_INSTALL_DIR}
+)