summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2023-01-19 05:28:18 +0100
committerSlávek Banko <slavek.banko@axis.cz>2023-01-19 05:34:48 +0100
commitb1a3fa8599e2fc84906cd9877f3efca3ce3238ce (patch)
tree4d28d39d6772ca8dbc8d0b03858ac211185fc88e /CMakeLists.txt
parentfcd778d34cebbaf4f26fd13b355f82f56d46692f (diff)
downloadtdeio-locate-b1a3fa8599e2fc84906cd9877f3efca3ce3238ce.tar.gz
tdeio-locate-b1a3fa8599e2fc84906cd9877f3efca3ce3238ce.zip
Cleanup CMake rules:r14.1.0
+ Add the option for building with hidden visibility. + Use the result of long files support tests instead of hard-coded definition. + Add the presence test TDEIO::UDS_HIDDEN. + Remove unnecessary tests. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 7 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 599bc5b..48826da 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,6 +45,12 @@ include( TDESetupPaths )
tde_setup_paths( )
+##### optional stuff
+
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+
+
##### user requested modules ####################
option( BUILD_ALL "Build all" OFF )
@@ -59,10 +65,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings #################
-add_definitions(
- -DHAVE_CONFIG_H
- -D_LARGEFILE64_SOURCE
-)
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )