summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <g-gregory@gmx.fr>2019-01-12 13:44:52 +0100
committergregory guy <g-gregory@gmx.fr>2019-01-12 13:44:52 +0100
commitc582b3bf38f9d95e8af05b28a3d653e96ead5dea (patch)
treecbd9b506c4a4f8328f43bb6702aed590b903544e /src/CMakeLists.txt
parentb9d222d7cd91bc81b5f5db3036108f8eed9dceb4 (diff)
downloadtdeio-sword-c582b3bf38f9d95e8af05b28a3d653e96ead5dea.tar.gz
tdeio-sword-c582b3bf38f9d95e8af05b28a3d653e96ead5dea.zip
conversion to the cmake building system
Signed-off-by: gregory guy <g-gregory@gmx.fr>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt49
1 files changed, 49 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..1697ec1
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,49 @@
+add_subdirectory( data )
+add_subdirectory( pics )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${LIBSWORD_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### tdeio_sword (kpart)
+
+tde_add_kpart( tdeio_sword AUTOMOC
+
+ SOURCES
+ tdeio_sword.cpp
+ renderer.cpp
+ ks_osishtml.cpp
+ ks_gbfhtml.cpp
+ ks_thmlhtml.cpp
+ utils.cpp
+ swordutils.cpp
+ swordoptions.cpp
+ filter.cpp
+ template.cpp
+ plainhtml.cpp
+ LINK
+ tdecore-shared
+ tdeio-shared
+ ${LIBSWORD_LIBRARY}
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ FILES sword.protocol
+ DESTINATION ${SERVICES_INSTALL_DIR}
+)