summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-29 17:16:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-29 17:16:51 +0200
commit6a19638974f29872747997ed1429a3ea52085bf2 (patch)
treecc1cb1e06a87e218c62df09d60ff87fcfcd05b6d /CMakeLists.txt
parent870bbf275ac45cf0e7d0ad4ce572272a2a5d6aa5 (diff)
downloadtdeio-umountwrapper-6a196389.tar.gz
tdeio-umountwrapper-6a196389.zip
Use common rules for build and install translations.
Change CMake project name to tdeio_umountwrapper. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 21a4c9fd75710b3c59ce6c601b5686831ecbc25c)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2c50362..de30551 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,7 +12,7 @@ cmake_minimum_required( VERSION 2.8.12 )
#### general package setup
-project( tdeio-umountwrapper )
+project( tdeio_umountwrapper )
set( VERSION R14.0.11 )
@@ -67,7 +67,11 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
tde_conditional_add_subdirectory( BUILD_ALL src )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files