summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-12-13 03:29:22 +0100
committerSlávek Banko <slavek.banko@axis.cz>2018-12-13 03:29:41 +0100
commit7422af7c1fb9accde0b1880b4eb6a58e2244b6ce (patch)
treeb69bde64c55562d1a21507a52a23df1b45836f15 /CMakeLists.txt
parent320de726f9e2cbb4a7fcf0265861eef30bb33df4 (diff)
downloadtdeio-umountwrapper-7422af7c1fb9accde0b1880b4eb6a58e2244b6ce.tar.gz
tdeio-umountwrapper-7422af7c1fb9accde0b1880b4eb6a58e2244b6ce.zip
Add CMakeL10n rules.
Create translation template. Add CMake rules to build translations. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit ce24f7e8bee0d70bdebe4e979eaefdb56c1b3ebb)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6ce2680..d7b4f12 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,6 +46,7 @@ option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden"
##### user requested modules
option( BUILD_ALL "Build all" ON )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks
@@ -65,6 +66,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
##### directories
tde_conditional_add_subdirectory( BUILD_ALL src )
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
##### write configure files