summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDarrell Anderson <humanreadable@yahoo.com>2013-04-23 08:59:44 -0500
committerDarrell Anderson <humanreadable@yahoo.com>2013-04-23 08:59:44 -0500
commit274dd3ccb3dd38866e87c83bd5e6f1085ba861d9 (patch)
tree60be5e7765163bf072bbe7a21ca34800c59897c5 /CMakeLists.txt
parent8188a65884ac1bca0aea32c5fdbaa19bc3b868f0 (diff)
downloadtdelibs-274dd3ccb3dd38866e87c83bd5e6f1085ba861d9.tar.gz
tdelibs-274dd3ccb3dd38866e87c83bd5e6f1085ba861d9.zip
Fix XDG ShowOnlyIn/NotShowIn conflicts with KDE4. Add cmake
WITH_OLD_XDG_STD configure support to retain old style support for potential problematic distros. This resolves bug report 1364.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d6d9f2441..a152c9ccf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,6 +88,7 @@ option( WITH_UDISKS "Enable UDISKS support" ${WITH_ALL_OPTIONS} )
option( WITH_UDISKS2 "Enable UDISKS2 support" ${WITH_ALL_OPTIONS} )
OPTION( WITH_NETWORK_MANAGER_BACKEND "Enable network-manager support" OFF )
OPTION( WITH_SUDO_TDESU_BACKEND "Use sudo as backend for tdesu (default is su)" OFF )
+OPTION( WITH_OLD_XDG_STD "Use the pre R14.0.0 XDG standard where both TDE and KDE are recognized in desktop files" OFF )
OPTION( WITH_ASPELL "Enable aspell support" ${WITH_ALL_OPTIONS} )
OPTION( WITH_HSPELL "Enable hspell support" ${WITH_ALL_OPTIONS} )