summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-08-23 18:19:49 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-08-23 18:19:49 -0500
commit32e6eba8731f7f3328ae287d0493d941dadec06f (patch)
treeac81ffbe137bb27cbd5681f25324f2ae340cd294 /CMakeLists.txt
parent38f05d1e1d61ac758d820a3923e2922337d9908e (diff)
downloadtdelibs-32e6eba8731f7f3328ae287d0493d941dadec06f.tar.gz
tdelibs-32e6eba8731f7f3328ae287d0493d941dadec06f.zip
Initial skeleton for network manager support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ceaa5eb6f..78d72aa9e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -83,6 +83,7 @@ OPTION( WITH_PCRE "Enable pcre regex support for kjs" ON )
OPTION( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
OPTION( WITH_INOTIFY "Enable inotify support for kio" ON )
OPTION( WITH_GAMIN "Enable FAM/GAMIN support" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_NETWORK_MANAGER_BACKEND "Enable network-manager support" OFF )
OPTION( WITH_ASPELL "Enable aspell support" ${WITH_ALL_OPTIONS} )
OPTION( WITH_HSPELL "Enable hspell support" ${WITH_ALL_OPTIONS} )
@@ -767,6 +768,31 @@ if( WITH_PCRE )
endif( )
+if( WITH_NETWORK_MANAGER_BACKEND )
+ ##### check for dbus-1 ###########################
+ pkg_search_module( DBUS dbus-1 )
+ if( NOT DBUS_FOUND )
+ tde_message_fatal( "dbus-1 are required, but not found on your system" )
+ endif( )
+
+
+ ##### check for dbus-1-tqt ###########################
+ pkg_search_module( DBUS_TQT dbus-1-tqt )
+ if( DBUS_TQT_FOUND )
+ find_program( DBUSXML2QT3_EXECUTABLE NAMES dbusxml2qt3 )
+ else()
+ tde_message_fatal( "dbus-1-tqt are required, but not found on your system" )
+ endif( )
+
+
+ ##### check for libnm-util ###########################
+ pkg_search_module( NM_UTIL libnm-util )
+ if( NOT NM_UTIL_FOUND )
+ tde_message_fatal( "libnm-util are required, but not found on your system" )
+ endif( )
+endif( WITH_NETWORK_MANAGER_BACKEND )
+
+
##### check for gcc visibility support #########
# FIXME
# This should check for [T]Qt3 visibility support