summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-03-21 06:49:42 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-03-21 06:49:42 +0000
commit6273a4300ee3538b3370e72438685bd6f57b9791 (patch)
tree12cdb6b222c2baca1ee117eda0f9ba1f245dde92 /CMakeLists.txt
parentdfe8053a7296cbf1924ea0149ff8bd6795fea6cb (diff)
downloadtdelibs-6273a4300ee3538b3370e72438685bd6f57b9791.tar.gz
tdelibs-6273a4300ee3538b3370e72438685bd6f57b9791.zip
Disable avahi-qt3 check under Qt4
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1225483 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 10 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 87201823a..de3701575 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -713,11 +713,16 @@ endif( WITH_LUA )
##### check for avahi ###########################
if( WITH_AVAHI )
- pkg_search_module( AVAHI avahi-qt3 )
- if( NOT AVAHI_FOUND )
- message(FATAL_ERROR "\navahi support are requested, but not found on your system" )
- endif( NOT AVAHI_FOUND )
- set( AVAHI_API_0_6 1 )
+ if( WITH_QT4 )
+ endif( WITH_QT4 )
+
+ if( WITH_QT3 )
+ pkg_search_module( AVAHI avahi-qt3 )
+ if( NOT AVAHI_FOUND )
+ message(FATAL_ERROR "\navahi support are requested, but not found on your system" )
+ endif( NOT AVAHI_FOUND )
+ set( AVAHI_API_0_6 1 )
+ endif( WITH_QT3 )
endif( )
##### check for aspell ##########################