summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-01-11 16:26:55 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-01-11 16:26:55 -0600
commit7845d1204e75630251bc9fac4f65c0be8a0f617b (patch)
tree3f695602836e36e48e37fefe374046c405ddafb9 /CMakeLists.txt
parentc2fb83dad7c2d075c0e9eec083b9d267c79abb6b (diff)
downloadtdelibs-7845d1204e75630251bc9fac4f65c0be8a0f617b.tar.gz
tdelibs-7845d1204e75630251bc9fac4f65c0be8a0f617b.zip
Add WITH_ALL_OPTIONS to CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt26
1 files changed, 14 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ede0a3a4c..5ce186bda 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,29 +59,31 @@ add_custom_target(install-apidox
##### user requested options ####################
+OPTION( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+
OPTION( KDE_MALLOC "Use own malloc implementation" OFF )
OPTION( KDE_MALLOC_DEBUG "Enable debugging in fast malloc" OFF )
OPTION( KDE_MALLOC_FULL "Make alloc as fast as possible" OFF )
OPTION( WITH_ARTS "Build with aRts" ON )
OPTION( WITH_ALSA "Enable ALSA support" ON )
-OPTION( WITH_LIBART "Enable libart support (for SVG icons)" OFF )
-OPTION( WITH_LIBIDN "Enable support for libidn" OFF )
+OPTION( WITH_LIBART "Enable libart support (for SVG icons)" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_LIBIDN "Enable support for libidn" ${WITH_ALL_OPTIONS} )
OPTION( WITH_SSL "Enable support for SSL" ON )
OPTION( WITH_CUPS "Enable CUPS support" ON )
-OPTION( WITH_LUA "Enable LUA support" OFF )
-OPTION( WITH_TIFF "Enable tiff support" OFF )
-OPTION( WITH_JASPER "Enable jasper (jpeg2k) support" OFF )
-OPTION( WITH_OPENEXR "Enable openexr support" OFF )
-OPTION( WITH_UTEMPTER "Use utempter for utmp management" OFF )
-OPTION( WITH_AVAHI "Enable AVAHI support" OFF )
-OPTION( WITH_ELFICON "Enable ELF embedded icon support" OFF )
+OPTION( WITH_LUA "Enable LUA support" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_TIFF "Enable tiff support" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_JASPER "Enable jasper (jpeg2k) support" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_OPENEXR "Enable openexr support" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_UTEMPTER "Use utempter for utmp management" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_AVAHI "Enable AVAHI support" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_ELFICON "Enable ELF embedded icon support" ${WITH_ALL_OPTIONS} )
OPTION( WITH_PCRE "Enable pcre regex support for kjs" ON )
-OPTION( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" OFF )
+OPTION( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
OPTION( WITH_INOTIFY "Enable inotify support for kio" ON )
-OPTION( WITH_ASPELL "Enable aspell support" OFF )
-OPTION( WITH_HSPELL "Enable hspell support" OFF )
+OPTION( WITH_ASPELL "Enable aspell support" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_HSPELL "Enable hspell support" ${WITH_ALL_OPTIONS} )
##### set PKG_CONFIG_PATH #######################