summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrançois Andriot <francois.andriot@free.fr>2014-10-07 01:00:47 +0200
committerSlávek Banko <slavek.banko@axis.cz>2014-10-07 01:34:09 +0200
commit84e3f9e06ba1b6a050e838ca55970f018e81b749 (patch)
treec0b5c29503c24bba5339eab5191a692ddbb674dc /CMakeLists.txt
parente255a8ca6387cc1f100beffe39f889328e8f2a41 (diff)
downloadtdelibs-84e3f9e06ba1b6a050e838ca55970f018e81b749.tar.gz
tdelibs-84e3f9e06ba1b6a050e838ca55970f018e81b749.zip
Allow conditional build of tdehwlib
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ac8d02304..45f161b0e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -85,7 +85,8 @@ OPTION( WITH_PCRE "Enable pcre regex support for kjs" ON )
OPTION( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
OPTION( WITH_INOTIFY "Enable inotify support for tdeio" ON )
OPTION( WITH_GAMIN "Enable FAM/GAMIN support" ${WITH_ALL_OPTIONS} )
-option( WITH_TDEHWLIB_DAEMONS "Enable daemons for TDE hwlib" ${WITH_ALL_OPTIONS} )
+option( WITH_TDEHWLIB "Enable TDE hwlib globally" ON )
+option( WITH_TDEHWLIB_DAEMONS "Enable daemons for TDE hwlib" ${WITH_TDEHWLIB} )
option( WITH_HAL "Enable HAL support" OFF )
option( WITH_DEVKITPOWER "Enable DeviceKit Power support" OFF )
option( WITH_LOGINDPOWER "Enable Logind/Systemd Power support" OFF )
@@ -506,6 +507,10 @@ set( LTDL_OBJDIR \".\" )
set( KDELIBSUFF "${LIB_SUFFIX}" )
set( kde_socklen_t socklen_t )
+if( WITH_TDEHWLIB )
+ set( __TDE_HAVE_TDEHWLIB 1 )
+endif( WITH_TDEHWLIB )
+
##### check for libdl ###########################