summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2013-08-01 19:05:28 -0500
committerDarrell Anderson <humanreadable@yahoo.com>2013-08-01 19:05:28 -0500
commitbe31b51dbc54328b836ebe216ff5c59c017f1c51 (patch)
treed9014ab5bfb3221fd2cf3d832159ec828b7a81d9 /CMakeLists.txt
parentcf1952a44719525ef5519bae6fd0a020512e67a5 (diff)
downloadtdelibs-be31b51dbc54328b836ebe216ff5c59c017f1c51.tar.gz
tdelibs-be31b51dbc54328b836ebe216ff5c59c017f1c51.zip
Fix FTBFS when xrender is missing.
This resolves bug report 1554.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b9d179433..324f07b66 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -591,6 +591,8 @@ endif( XRANDR_FOUND )
pkg_search_module( XRENDER xrender )
if( XRENDER_FOUND )
set( HAVE_XRENDER 1 )
+else( XRENDER_FOUND)
+ message(FATAL_ERROR "\nxrender support is required, but not found on your system" )
endif( XRENDER_FOUND )
##### check for xcomposite #########################