summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2015-06-14 20:27:02 +0200
committerSlávek Banko <slavek.banko@axis.cz>2015-06-14 20:27:02 +0200
commite75569be1b7bf138685d0e4941daf111e6f51ba3 (patch)
treeaa5eae384c38e0f11e2f7a33cbf959719f176780 /CMakeLists.txt
parent14243cc8ead795531e47954763cc8b1bec94a092 (diff)
downloadtdelibs-e75569be1b7bf138685d0e4941daf111e6f51ba3.tar.gz
tdelibs-e75569be1b7bf138685d0e4941daf111e6f51ba3.zip
Fix openpty detection with libutil.h
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 8 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ca577fe63..55f61c87f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -472,20 +472,16 @@ endif( HAVE_RES_INIT)
set( CMAKE_REQUIRED_LIBRARIES util )
if( HAVE_PTY_H )
- check_c_source_runs("
- #include <pty.h>
- int main(int argc, char* argv) {
- int master_fd, slave_fd;
- int result;
- result = openpty(&master_fd, &slave_fd, 0, 0, 0);
- return 0;
- }"
- HAVE_OPENPTY
- )
+ set( USE_OPENPTY_H pty.h )
elseif( HAVE_UTIL_H )
+ set( USE_OPENPTY_H util.h )
+elseif( HAVE_LIBUTIL_H )
+ set( USE_OPENPTY_H libutil.h )
+endif( )
+if( USE_OPENPTY_H )
check_c_source_runs("
- #include <util.h>
- int main(int argc, char* argv) {
+ #include <${USE_OPENPTY_H}>
+ int main(int argc, char* argv[]) {
int master_fd, slave_fd;
int result;
result = openpty(&master_fd, &slave_fd, 0, 0, 0);