summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-01-15 16:54:53 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-01-15 16:54:53 -0600
commit2b035349c31fe64c31d2c050892b117a3a807179 (patch)
tree0ebd2ee45b2bd32a7e3800556fde6cf4c8777f66 /CMakeLists.txt
parent98fd239bd75a129965c0d4f56a4cc5bad3e0a175 (diff)
downloadtdelibs-2b035349c31fe64c31d2c050892b117a3a807179.tar.gz
tdelibs-2b035349c31fe64c31d2c050892b117a3a807179.zip
Add fam/gamin support to tdelibs CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5ce186bda..a1a64292c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -81,6 +81,7 @@ OPTION( WITH_ELFICON "Enable ELF embedded icon support" ${WITH_ALL_OPTIONS} )
OPTION( WITH_PCRE "Enable pcre regex support for kjs" ON )
OPTION( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
OPTION( WITH_INOTIFY "Enable inotify support for kio" ON )
+OPTION( WITH_GAMIN "Enable FAM/GAMIN support" ${WITH_ALL_OPTIONS} )
OPTION( WITH_ASPELL "Enable aspell support" ${WITH_ALL_OPTIONS} )
OPTION( WITH_HSPELL "Enable hspell support" ${WITH_ALL_OPTIONS} )
@@ -786,6 +787,23 @@ if( WITH_INOTIFY )
endif( )
+##### check for FAM/GAMIN ##########################
+
+if( WITH_GAMIN )
+ check_include_file( "fam.h" HAVE_FAM_H )
+ if( HAVE_FAM_H )
+ pkg_search_module( GAMIN gamin )
+ if( GAMIN_FOUND )
+ set( HAVE_FAM 1 )
+ else( GAMIN_FOUND )
+ message(FATAL_ERROR "\nfam/gamin support was requested, but gamin was not found on your system" )
+ endif( GAMIN_FOUND )
+ else( HAVE_FAM_H )
+ message(FATAL_ERROR "\nfam/gamin support was requested, but fam was not found on your system" )
+ endif( HAVE_FAM_H )
+endif( WITH_GAMIN )
+
+
##### check for aspell ##########################
# we need ASPELL_DATADIR too