summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-14 00:55:22 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-14 00:55:22 -0600
commitd3264970c374983ec6f7b55f468334e80513fae3 (patch)
tree07379c8ad25171a1ac55461ee237c6c00c38df37 /CMakeLists.txt
parent4c9ff70f806c4e8f2f6197b94db39b5bef8c71f2 (diff)
downloadtdelibs-d3264970c374983ec6f7b55f468334e80513fae3.tar.gz
tdelibs-d3264970c374983ec6f7b55f468334e80513fae3.zip
Use upower for suspend and hibernate if direct access to sysfs is not allowed
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 74f783b02..37a05bf5c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -83,6 +83,7 @@ OPTION( WITH_PCRE "Enable pcre regex support for kjs" ON )
OPTION( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
OPTION( WITH_INOTIFY "Enable inotify support for kio" ON )
OPTION( WITH_GAMIN "Enable FAM/GAMIN support" ${WITH_ALL_OPTIONS} )
+option( WITH_UPOWER "Enable UPOWER support" ${WITH_ALL_OPTIONS} )
OPTION( WITH_NETWORK_MANAGER_BACKEND "Enable network-manager support" OFF )
OPTION( WITH_SUDO_TDESU_BACKEND "Use sudo as backend for tdesu (default is su)" OFF )