summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2014-10-08 15:38:32 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2014-10-08 15:38:32 -0500
commite1eaf5a90159b023cb4c0c9e5c68acba397c1457 (patch)
tree1d2667967ffe2d9e5ee2d0ae7bab6dbebc990073 /CMakeLists.txt
parenta71fa0953d227ac2b418a4acd1602db4ecf55825 (diff)
parentaae8990d33bbfee205c75dc7e48e1c64f2beeff0 (diff)
downloadtdelibs-e1eaf5a90159b023cb4c0c9e5c68acba397c1457.tar.gz
tdelibs-e1eaf5a90159b023cb4c0c9e5c68acba397c1457.zip
Merge branch 'master' of https://scm.trinitydesktop.org/scm/git/tdelibs
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 45f161b0e..11d3c4bfe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -679,6 +679,12 @@ if( WITH_XCOMPOSITE )
else( WITH_XCOMPOSITE )
tde_message_fatal( "xcomposite support was requested, but xcomposite was not found on your system" )
endif( XCOMPOSITE_FOUND )
+
+ # xext (tderandr, tdestyles/keramik, tdeui)
+ pkg_search_module( XEXT xext )
+ if( NOT XEXT_FOUND )
+ tde_message_fatal( "xext is required for xcomposite support, but was not found on your system" )
+ endif( )
endif( WITH_XCOMPOSITE )