summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOBATA Akio <obache@wizdas.com>2020-08-16 18:15:33 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-08-17 23:07:26 +0900
commita6be89461fec308f187f811ad952fc2b4019c561 (patch)
tree12105b32217b7c8061741bc7a47d4e578a954f35 /CMakeLists.txt
parentf5a0ae91d37e4b965a3c26c9791e2958bb789754 (diff)
downloadtdelibs-a6be89461fec308f187f811ad952fc2b4019c561.tar.gz
tdelibs-a6be89461fec308f187f811ad952fc2b4019c561.zip
Allow to use backtrace(3) external library for kdebug
Signed-off-by: OBATA Akio <obache@wizdas.com> (cherry picked from commit 2167207adc49b498536a5a8533c27fc67e0c6e9c)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9f646b13e..d1b2c29a0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -330,7 +330,18 @@ check_symbol_exists( gethostbyname2_r "netdb.h" HAVE_GETHOSTBYNAME2_R )
check_symbol_exists( gethostbyname_r "netdb.h" HAVE_GETHOSTBYNAME_R )
check_symbol_exists( gai_strerror "sys/types.h;sys/socket.h;netdb.h" HAVE_GAI_STRERROR )
check_symbol_exists( getaddrinfo "sys/types.h;sys/socket.h;netdb.h" HAVE_GETADDRINFO )
-check_symbol_exists( backtrace "execinfo.h" HAVE_BACKTRACE )
+if ( CMAKE_MAJOR_VERSION LESS "3" )
+ check_symbol_exists( backtrace "execinfo.h" HAVE_BACKTRACE )
+ if ( HAVE_BACKTRACE )
+ set ( Backtrace_LIBRARY "" )
+ set ( Backtrace_HEADER "execinfo.h" )
+ endif ()
+else ()
+ find_package( Backtrace )
+ if ( Backtrace_FOUND )
+ set ( HAVE_BACKTRACE 1 )
+ endif ()
+endif ()
check_cxx_source_compiles( "#include <cxxabi.h>
int main() { abi::__cxa_demangle(0, 0, 0, 0); return 0; }"
HAVE_ABI_CXA_DEMANGLE )