summaryrefslogtreecommitdiffstats
path: root/kate/part/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce4a32fe52ef09d8f5ff1dd22c001110902b60a2 (patch)
tree5ac38a06f3dde268dc7927dc155896926aaf7012 /kate/part/Makefile.am
downloadtdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.tar.gz
tdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kate/part/Makefile.am')
-rw-r--r--kate/part/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/kate/part/Makefile.am b/kate/part/Makefile.am
new file mode 100644
index 000000000..4a182452e
--- /dev/null
+++ b/kate/part/Makefile.am
@@ -0,0 +1,44 @@
+kde_module_LTLIBRARIES = libkatepart.la
+
+noinst_LTLIBRARIES = libkate.la
+
+libkate_la_SOURCES = katesearch.cpp katebuffer.cpp katecmds.cpp \
+ kateundo.cpp katecursor.cpp katedialogs.cpp katedocument.cpp \
+ katefactory.cpp katehighlight.cpp katesyntaxdocument.cpp \
+ katetextline.cpp kateview.cpp kateconfig.cpp kateviewhelpers.cpp \
+ katecodecompletion.cpp katedocumenthelpers.cpp \
+ katecodefoldinghelpers.cpp kateviewinternal.cpp katebookmarks.cpp \
+ kateprinter.cpp katefont.cpp katelinerange.cpp katesupercursor.cpp \
+ katearbitraryhighlight.cpp katerenderer.cpp kateattribute.cpp \
+ kateautoindent.cpp katefiletype.cpp kateschema.cpp katedocument.skel \
+ katetemplatehandler.cpp katejscript.cpp katespell.cpp kateindentscriptabstracts.cpp \
+ kateluaindentscript.cpp
+
+libkatepart_la_SOURCES = dummy.cpp
+
+libkatepart_la_LIBADD = libkate.la ../interfaces/libkatepartinterfaces.la $(top_builddir)/kdeprint/libkdeprint.la $(top_builddir)/kutils/libkutils.la $(top_builddir)/kjs/libkjs.la $(LUA_LIBS)
+
+libkatepart_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+
+INCLUDES= -I../interfaces -I$(top_srcdir) -I$(top_srcdir)/kdeprint -I$(top_srcdir)/interfaces -I$(top_srcdir)/interfaces/kregexpeditor -I$(top_srcdir)/kdefx -I$(top_srcdir)/kutils -I$(top_builddir)/kjs $(LUA_INCLUDES) $(all_includes)
+
+METASOURCES = AUTO
+
+LUT_FILES = katejscript.lut.h
+
+CREATE_HASH_TABLE = $(top_srcdir)/kjs/create_hash_table
+
+dummy.cpp: $(srcdir)/Makefile.am
+ touch $@
+
+katejscript.lut.h : $(srcdir)/katejscript.cpp $(CREATE_HASH_TABLE)
+ $(PERL) $(CREATE_HASH_TABLE) $(srcdir)/katejscript.cpp > $@
+katejscript.lo: katejscript.lut.h
+
+CLEANFILES = $(LUT_FILES)
+
+## test program
+TESTS = testkateregression
+check_PROGRAMS = testkateregression
+testkateregression_SOURCES = test_regression.cpp
+testkateregression_LDADD = $(libkatepart_la_LIBADD)