summaryrefslogtreecommitdiffstats
path: root/kio/kio/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2013-08-17 13:21:22 +0200
committerSlávek Banko <slavek.banko@axis.cz>2015-12-23 02:22:28 +0100
commit5bb41966dbc963d39c9660de7c9bbd7bcc2b9553 (patch)
tree0f56db475189e6edbbfd587a7da242fac684300d /kio/kio/CMakeLists.txt
parent9d581b3f4c12d3b8f375250116c652f8abba025e (diff)
downloadtdelibs-5bb41966dbc963d39c9660de7c9bbd7bcc2b9553.tar.gz
tdelibs-5bb41966dbc963d39c9660de7c9bbd7bcc2b9553.zip
Added check the conditions for building backtrace handler
(cherry picked from commit 35748811a4b11b5947879f657a752e89d649ce06)
Diffstat (limited to 'kio/kio/CMakeLists.txt')
-rw-r--r--kio/kio/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/kio/kio/CMakeLists.txt b/kio/kio/CMakeLists.txt
index 17d33feb2..ebc7dc2ed 100644
--- a/kio/kio/CMakeLists.txt
+++ b/kio/kio/CMakeLists.txt
@@ -80,13 +80,18 @@ set( ${target}_SRCS
kdirnotify.cpp kdirnotify.skel kdirnotify_stub.cpp
observer.cpp ../misc/uiserver.stub observer.skel kemailsettings.cpp
kprotocolinfo.cpp renamedlg.cpp skipdlg.cpp kremoteencoding.cpp
- kmimetypechooser.cpp backtrace_symbols.c
+ kmimetypechooser.cpp
)
+if( HAVE_BACKTRACE AND HAVE_DEMANGLE_H )
+ list( APPEND ${target}_SRCS backtrace_symbols.c )
+ set( BACKTRACE_LIBRARY bfd )
+endif( )
+
tde_add_library( ${target} STATIC_PIC AUTOMOC
SOURCES ${${target}_SRCS}
DEPENDENCIES dcopidl
- LINK bfd
+ LINK ${BACKTRACE_LIBRARY}
)