summaryrefslogtreecommitdiffstats
path: root/tdecore/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-14 00:55:22 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-14 00:55:22 -0600
commitd3264970c374983ec6f7b55f468334e80513fae3 (patch)
tree07379c8ad25171a1ac55461ee237c6c00c38df37 /tdecore/CMakeLists.txt
parent4c9ff70f806c4e8f2f6197b94db39b5bef8c71f2 (diff)
downloadtdelibs-d3264970c374983ec6f7b55f468334e80513fae3.tar.gz
tdelibs-d3264970c374983ec6f7b55f468334e80513fae3.zip
Use upower for suspend and hibernate if direct access to sysfs is not allowed
Diffstat (limited to 'tdecore/CMakeLists.txt')
-rw-r--r--tdecore/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tdecore/CMakeLists.txt b/tdecore/CMakeLists.txt
index 2e00d6afa..f0ea3b5b4 100644
--- a/tdecore/CMakeLists.txt
+++ b/tdecore/CMakeLists.txt
@@ -14,6 +14,13 @@ add_subdirectory( network )
add_subdirectory( kconfig_compiler )
add_subdirectory( hwlibdata )
+if( NOT DBUS_SYSTEM_BUS )
+ set( DBUS_SYSTEM_BUS "unix:path=/var/run/dbus/system_bus_socket" CACHE INTERNAL "" FORCE )
+endif()
+
+if( WITH_UPOWER )
+ add_definitions( -DWITH_UPOWER )
+endif( )
if( WITH_LIBART )
add_subdirectory( svgicons )