summaryrefslogtreecommitdiffstats
path: root/tdecore/CMakeLists.txt
diff options
context:
space:
mode:
authorGolubev Alexander <fatzer2@gmail.com>2013-07-27 10:34:20 +0400
committerGolubev Alexander <fatzer2@gmail.com>2013-07-27 11:20:18 +0400
commit0984f0194709db2d85651615b0551054876dbcc5 (patch)
treed8fe42c304827d5108b816c84898c06cf3ab40f1 /tdecore/CMakeLists.txt
parent70ce443ca384bef01d896a5e1dc81acb90f3df51 (diff)
downloadtdelibs-0984f0194709db2d85651615b0551054876dbcc5.tar.gz
tdelibs-0984f0194709db2d85651615b0551054876dbcc5.zip
move all tdehw stuff into separate subdir
Diffstat (limited to 'tdecore/CMakeLists.txt')
-rw-r--r--tdecore/CMakeLists.txt59
1 files changed, 7 insertions, 52 deletions
diff --git a/tdecore/CMakeLists.txt b/tdecore/CMakeLists.txt
index bff0e51d0..59bccf568 100644
--- a/tdecore/CMakeLists.txt
+++ b/tdecore/CMakeLists.txt
@@ -12,61 +12,20 @@
add_subdirectory( malloc )
add_subdirectory( network )
add_subdirectory( tdeconfig_compiler )
-add_subdirectory( hwlibdata )
-add_subdirectory( hwlibdaemons )
-
-if( NOT DBUS_SYSTEM_BUS )
- set( DBUS_SYSTEM_BUS "unix:path=/var/run/dbus/system_bus_socket" CACHE INTERNAL "" FORCE )
-endif()
-
-if( WITH_UPOWER )
- add_definitions( -DWITH_UPOWER )
- set ( TDEUPOWER_INCLUDE_DIRECTORIES
- ${DBUS_TQT_INCLUDE_DIRS}
- )
- set ( TDEUPOWER_LIBRARIES
- ${DBUS_TQT_LIBRARIES}
- )
-endif( )
-
-if( WITH_UDISKS )
- add_definitions( -DWITH_UDISKS )
-endif( )
-
-if( WITH_UDISKS2 )
- add_definitions( -DWITH_UDISKS2 )
-endif( )
-
-if( WITH_CONSOLEKIT )
- add_definitions( -DWITH_CONSOLEKIT )
-endif( )
+add_subdirectory( tdehw )
if( WITH_LIBART )
add_subdirectory( svgicons )
set( KDESVGICONS kdesvgicons-static )
endif( WITH_LIBART )
-if( WITH_NETWORK_MANAGER_BACKEND )
- add_subdirectory( networkbackends/network-manager/dbus )
- set ( TDENM_INCLUDE_DIRECTORIES
- ${DBUS_TQT_INCLUDE_DIRS}
- ${NM_UTIL_INCLUDE_DIRS}
- "${CMAKE_BINARY_DIR}/tdecore/networkbackends/network-manager/dbus"
- )
- set ( TDENM_LIBRARIES
- tdenm_dbus-static
- ${DBUS_TQT_LIBRARIES}
- )
- set ( TDENM_BACKEND_SOURCES networkbackends/network-manager/network-manager.cpp )
-endif( WITH_NETWORK_MANAGER_BACKEND )
-
-
include_directories(
${TQT_INCLUDE_DIRS}
${CMAKE_CURRENT_BINARY_DIR}
${CMAKE_BINARY_DIR}
${CMAKE_CURRENT_SOURCE_DIR}
${CMAKE_CURRENT_SOURCE_DIR}/network
+ ${CMAKE_CURRENT_SOURCE_DIR}/tdehw
${CMAKE_SOURCE_DIR}/dcop
${CMAKE_SOURCE_DIR}/libltdl
${CMAKE_SOURCE_DIR}/tdefx
@@ -75,8 +34,6 @@ include_directories(
${LIBART_INCLUDE_DIRS}
${LIBIDN_INCLUDE_DIRS}
${GAMIN_INCLUDEDIR}
- ${TDENM_INCLUDE_DIRECTORIES}
- ${TDEUPOWER_INCLUDE_DIRECTORIES}
)
link_directories(
@@ -111,8 +68,7 @@ install( FILES
kcalendarsystem.h kcalendarsystemfactory.h kmacroexpander.h
kmanagerselection.h kmountpoint.h kuser.h klockfile.h
kidna.h ktempdir.h kshell.h fixx11h.h kxerrorhandler.h
- tdelibs_export.h kde_file.h ktimezones.h tdehardwaredevices.h
- tdenetworkconnections.h
+ tdelibs_export.h kde_file.h ktimezones.h
${CMAKE_CURRENT_BINARY_DIR}/kdemacros.h
DESTINATION ${INCLUDE_INSTALL_DIR} )
@@ -168,16 +124,15 @@ set( ${target}_SRCS
ktempdir.cpp kshell.cpp kmountpoint.cpp kcalendarsystemjalali.cpp
kprotocolinfo_tdecore.cpp kprotocolinfofactory.cpp kxerrorhandler.cpp
kuser.cpp tdeconfigskeleton.cpp tdeconfigdialogmanager.cpp klockfile.cpp
- kqiodevicegzip_p.cpp ktimezones.cpp tdehardwaredevices.cpp tdenetworkconnections.cpp
- ksimpledirwatch.cpp
- ${TDENM_BACKEND_SOURCES}
+ kqiodevicegzip_p.cpp ktimezones.cpp ksimpledirwatch.cpp
)
tde_add_library( ${target} SHARED AUTOMOC
SOURCES ${${target}_SRCS}
VERSION 4.2.0
- EMBED tdecorenetwork-static
- LINK ltdlc-static ${KDESVGICONS} DCOP-shared tdefx-shared ${ZLIB_LIBRARIES} ${LIBIDN_LIBRARIES} ${XCOMPOSITE_LIBRARIES} ICE SM udev ${GAMIN_LIBRARIES} ${TDENM_LIBRARIES} ${TDEUPOWER_LIBRARIES}
+ EMBED tdecorenetwork-static tdehw-static
+ LINK ltdlc-static ${KDESVGICONS} DCOP-shared tdefx-shared ${ZLIB_LIBRARIES}
+ ${LIBIDN_LIBRARIES} ${XCOMPOSITE_LIBRARIES} ICE SM ${GAMIN_LIBRARIES}
DEPENDENCIES dcopidl dcopidl2cpp
DESTINATION ${LIB_INSTALL_DIR}
)